The center for all Wikitravel images!

Difference between revisions of "Php error on image delete on en"

From Wikitravel Shared
Jump to: navigation, search
Php error on image delete on en

Default Banner.jpg

(Image deletion issue on en)
 
(close- appears resolved)
 
Line 13: Line 13:
  
 
== Additional comments ==
 
== Additional comments ==
 +
 +
I was seeing this too a while back, it was actually deleting the image despite the error message, if you purged the cache after deleting then it was gone... however I just tested again now, and this seems to have resolved itself &ndash; [[User:Cacahuate|<font color="green">cacahuate</font>]]  <sup><small>[[User talk:Cacahuate|<font color="blue">talk</font>]]</small></sup> 04:01, 14 October 2008 (EDT)
  
 
== Sign below, please ==
 
== Sign below, please ==
 
[[User:NJR ZA|NJR ZA]] 06:53, 3 June 2008 (EDT)
 
[[User:NJR ZA|NJR ZA]] 06:53, 3 June 2008 (EDT)
  
[[Category:Open bug reports]]
+
 
 +
 
 +
{{fixedbug}}

Latest revision as of 08:05, 14 October 2008

What happens[edit]

Image is deleted, but image article is not. The following php error appears on the top of the browser window:

Warning: chmod() [function.chmod]: Not owner in /var/www/wikitravel/mw-1.11.2/includes/filerepo/FSRepo.php on line 425

When it happens[edit]

On image delete on en

What should happen[edit]

Should not produce an error message. Should delete image article along with image.

How to fix it[edit]

Seems to be an authority issue. chown on those directories on the server should resolve it

Additional comments[edit]

I was seeing this too a while back, it was actually deleting the image despite the error message, if you purged the cache after deleting then it was gone... however I just tested again now, and this seems to have resolved itself – cacahuate talk 04:01, 14 October 2008 (EDT)

Sign below, please[edit]

NJR ZA 06:53, 3 June 2008 (EDT)