"Wikitravel has a speed and convenience the books' publishers can only envy." Time Europe

Tech:Listing editor interacts poorly with HTML comments

From Wikitravel Shared
Revision as of 02:07, 22 June 2012 by LtPowers (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

What happens[edit]

I occasionally see edits like this one, where an HTML comment is modified improperly by the listing editor. (Note that the user apparently thought he/she was editing the "Khayalethu Backpackers" listing, but instead a new "Khayalethu Backpackers" listing was created at the top of the article, where the HTML comment was located, and the text of the comment was incorporated into the listing!)

When it happens[edit]

Not sure if it happens every time there's an HTML comment or not, but I've seen it twice in the last week. The HTML comment could be anywhere in the article; it doesn't seem to matter where.

Update (12:15, 6 April 2011 (EDT)): This behavior only occurs in Internet Explorer. It does not occur in Firefox. In IE it appears to happen quite consistently if there are ANY HTML comments in the document. This is a major flaw in the listing editor. -- LtPowers


Do you know what specific versions of IE are doing this? Is it doing it with the more recent versions of the browser? IB-Dick 15:36, 23 August 2011 (EDT)

I've confirmed it occurring with IE 8.0. LtPowers 16:23, 23 August 2011 (EDT)
IE 9.0 appears to work correctly. LtPowers 16:27, 23 August 2011 (EDT)

What should happen[edit]

The comment should remain undisturbed and the listing editor should update the correct listing instead of trying to update the HTML comment.

How to fix it[edit]

Additional comments[edit]

Any update on this, or can we close the ticket? Riggwelter 16:39, 20 June 2012 (EDT)

I attempted to reproduce the bug using IE 8.0, but I am unable to edit any pages on the wiki at all using that browser. If a page is protected from editing (and I'm not logged in as an administrator), the "View source" page comes up just fine, but if the page is editable... no dice. So not only can I not test this bug, I seem to have found a new one. LtPowers 22:03, 21 June 2012 (EDT)

Sign below, please[edit]

-- LtPowers 10:27, 18 October 2010 (EDT)

Variants

Actions

In other languages