Help Wikitravel grow by contributing to an article! Learn how.

Wikitravel:Bug reports

From Wikitravel
Revision as of 03:45, 11 March 2006 by 218.111.21.95 (Talk)

Jump to: navigation, search

Contents

This page is for bug reports for the Wikitravel installation of Mediawiki 1.4.14. Bugs that have been verified as fixed already are under Wikitravel:Bug reports 1.4.3/Fixed. For older bug reports, see the Wikitravel:bug report archives.

Please, for each bug you find, start a new section on this page. It makes it easier to discuss each problem separately.

Space above the ToC box

There should be some empty space above the Table of Contents box

Too much space inside ToC box

There is too much empty space between subheadings in ToC box

Too much whitespace generally

There is too much whitespace generally! I think we have to adapt the main page and maybe other article to this new skin Monobook. Just an idea, though - Monobook is a CSS based design and is therefore very adaptable - we should change the background image, as well as the colour scheme, etc to make it look less Wikipedia-like (currently, it looks like a Wikimedia project ;-) Ronline 10:21, 8 Oct 2004 (EDT)

How about this? Lowres screenshot of some changes -- mo 18:35, 20 Oct 2004 (EDT)

  • The logo is not transparent - not really a bug, just something that looks weird at the present moment. Ronline 10:21, 8 Oct 2004 (EDT)

Self-links problems

  • Self-links - why e.g is Flanders in this list ? --Nzpcmad 03:36, 9 Oct 2004 (EDT)

I think it's because it includes Template:BelgiumRegions, which has a link to Flanders in it. Not sure, though. --Evan 17:59, 10 Oct 2004 (EDT)

I can't even find this feature any more. Can we get rid of this bug? --Evan 12:39, 3 Dec 2005 (EST)

Editing Section 0

When a page has section headings (like this one) it is no longer possible to clik on an [edit] link to edit the text before the first section heading as a separate section. Instead one must edit the whole page or click an edit section link and change the URL so the section number = 0. The functionality exists but the link does not. This is fine if there is no text before the heading but on WikiTravel, section 0 is where the introductory text and a lot of the wiki backlinking information is placed. In previous versions there were often 2 edits side by side, one for section 0, the other for section 1 when a heading was at the top of the page. It seems that this old bug has been over-corrected. Could an [edit] appear on the section 0 text if it exists?

My understanding is that this is by design -- I can't remember the reasoning, but when I asked on IRC Tim Starling said this had been removed on purpose. I'll follow up. --Evan 12:40, 3 Dec 2005 (EST)

Caching and user preferences

User preferences are effectively disabled for now. This is an unfortunate consequence of serving static HTML files; everyone gets the same files. I'm going to be working on adding alternate style sheets using this method, but it's going to have to wait until the new caching system stabilizes. In other words, it's a low-priority bug. A higher-priority bug, though, is that you still get most of your user preferences shown on the Special:Preferences page. --Evan 15:13, 18 Nov 2004 (EST)

Konqueror

The Javascript that sets the username links apparently doesn't work in Konqueror, so there's no indication on-screen whether you're logged in or not. --Evan 18:46, 18 Nov 2004 (EST)

Is this still true? --Evan 13:07, 3 Dec 2005 (EST)

I am having difficulties with konq too. For instance, I was just editing some pages on Munich, and while the top panel did show me as logged in (it showed 'Bulliver' and 'log out') the edits showed up as my IP. Also, the 'remember me' link on the login page has no effect. If I open a new Wikitravel page using 'open in new window' I stay logged in, but if I open a completely new window and navigate here, I need to log in again even if I still have another konq window open to Wikitravel. I think konq may prefer Chocolate chip to Wikitravel cookies... -- bulliver 03:55, 2 March 2006 (EST)

It more or less works for me using Konq 3.5.1. I does show me as logged in even though I am not when I switch between home and work. However since the first thing I hit is recent changes I can always tell anyhow. -- Mark 03:59, 2 March 2006 (EST)
Yes, I am also using 3.5.1. Seems to me Konqueror's JavaScript interpreter has always been somewhat flaky. -- bulliver 04:31, 2 March 2006 (EST)
Check that: I've just tested with Konq, Firefox and Epiphany and all three have 'My Page' at the top of the main page, but show 'Bulliver' once I've clicked it. Is this the intended behavior? -- bulliver 04:36, 2 March 2006 (EST)

Message notifications unavailable

Notifications of new messages on the Talk page have also stopped working after the proxy caching implementation. =/

First: there's no proxy.
Second: you're correct. That's by design; I don't want to see your new-message notification when I'm reading a page.
I'd like to roll out email notification such as http://meta.wikimedia.org/wiki/Enotif. It's not the same as the on-page notification, but it's about as close as we can get without checking at each hit.

Would it be possible to use the proxy caching system for unregistered users only (who, I imagine, make up the bulk of the load) and allow registered users to use the old customized system? Jpatokal 00:04, 19 Nov 2004 (EST)

It's possible, but a) it's going to take a while, b) I'm not sure it won't be enough to overheat the servers again, and c) I'm not sure it makes a lot of sense to penalize logged-in users by making them wait longer to read pages! --Evan 18:19, 19 Nov 2004 (EST)
May I suggest that some effort is put into this issue...and rather soon? Sv: suffers from daily sabotage, and since we have implemented sabotage warning templates, which we put on the misdemeanor's "talk" pages, we think it is very important that they get a chance to see that they are being watched and warned! Also, it would be nice to have it turned back on so the serious users may choose if they want to check their "talk" page or not when they log in - something which they HAVE to do nowadays. The new-message notification must of course be visible whenever there is a new message waiting for the user in question. BR Riggwelter 04:59, 10 Feb 2006 (EST)
I'm aware of the issue and I'm working on it. It's not a case of just "turning on" the feature, though. --Evan 09:55, 10 Feb 2006 (EST)
Sorry, I was not aware of that...I thought it was a "press-the-button" operation. Could you give me some more info on why the feature was deactivated? Apparently it had something to do with "overheated servers" and a "proxy caching implementation" ? Riggwelter 15:50, 13 Feb 2006 (EST)
this might give you some background. hth Majnoona 19:20, 13 Feb 2006 (EST)

I think that the message system is crucial for the success of this (sv:) wiki, without it people won't know that they can register, and anonymous users never tend to become regulars. I'm quite sure that if we keep up with the pace we have at the moment then users will pop in soon, but we will have to do quite a lot of work ourself, atleast during this spring. --Jonas Ryberg 22 februari 2006 kl.00.11 (CET)

I'm working on the 1.5 upgrade, and new message notification will be my next priority. I realize that this is very important to major contributors on sv: and I want to put effort into it to say thanks for your work. --Evan 10:13, 22 Feb 2006 (EST)
Evan, it is we who should be grateful for your work! Thanks for making it possible for us to build a great site. I hope we will live up to your expectations. =) Riggwelter 12:58, 22 Feb 2006 (EST)

I just would like to say that turning the message notification back on was a great thing to do. Thanks Evan and the guys from sv: for your efforts on that. Cheers, Ricardo (Rmx) 21:35, 9 March 2006 (EST)

Iframe doesn't work in Konqueror

The logbook on the Main Page is a mess, with text inside overwriting text outside, only to disappear when scrolled or highlighted. -phma 14:27, 20 Nov 2004 (EST)

I also don't have problems with the Iframe. The logbook looks perfectly normal to me, even in other language versions (still Konqueror 3.3 with KDE 3.3.0) -- mo 10:17, 21 Nov 2004 (EST)

Safari seems to have the same problem. (Safari 1.0.3 (v85.8.1) on OS X.2.8) On one line the text runs far enough as to have the last character appearing of the right side of my window. --Neil 04:05, 3 Jan 2005 (EST)

Special pages: popular pages

Popular pages don't get updated since the latest transfer to the new ISP.

Jens 16:39, 08 Dec 2004 (EST)

The page read counts is no longer being updated, since we're caching pages out as HTML. There are Web statistics available, but they're not very fine-grained. I can try to work on some more detailed stats in the future. --Evan 13:07, 3 Dec 2005 (EST)

Großglockner_Hochalpenstraße

An article served by a random page search at Großglockner_Hochalpenstraße is the same as Großglockner Hochalpenstraße, (since redirected to Grossglockner Hochalpenstrasse). The ß displayed as ß in both the article and title when served by the Special:Randompage. The two articles were identical, apparently. -- Huttite 04:11, 24 Jan 2005 (EST)

Error uploading large .svg file

It appears that Image:Paris.svg has outgrown the ability of Mediawiki to handle. When trying to upload I get the following error:


 Internal error

 Could not copy file "" to "/var/www/html/en/upload/5/57/Paris.svg".

And the following PHP error messages are dumped before the HTML is rendered:

 
Warning: fread(): supplied argument is not a valid stream resource in /var/www/html/en/includes/SpecialUpload.php on line 449

Warning: fclose(): supplied argument is not a valid stream resource in /var/www/html/en/includes/SpecialUpload.php on line 450
As a workaround you can try to use compressed .svgz format (svg+gzip). I think it's supported by most svg browsers. For sure by Adobe SVG Viewer. -- JanSlupski 18:09, 28 Jan 2005 (EST)
Good idea. Evan can you add that to the list of acceptable extensions? -- Mark 03:41, 5 Feb 2005 (EST)


I'm starting to do some U.S. maps using the Census Bureau Tigerline data. Since it's done by county the SVG versions work out to be really really big (for now), so the .svgz extension would be really fantastic now. -- Mark 05:48, 11 Mar 2005 (EST)


Image displayed incorrectly after size change

Image:Cusco_from_Sacsayhuamán_-_July_2003.jpg was reuploaded at a smaller size, but the page still displays it at the original size, with resulting gross distortion. The image itself is still intact though if you right-click and View Image. Jpatokal 11:17, 4 Apr 2005 (EDT)

Please check if it is fixed now. It seems that this is another instance of previous caching bug. Workaround is to manually reset server cache, for example by selecting Edit and then Save (without doing any change to the content, so edit wouldn't be even recored). --JanSlupski 19:18, 4 Apr 2005 (EDT)
Problem appears to have resolved itself and image displays OK now. -- Huttite 08:49, 6 Apr 2005 (EDT)
Well, just before posting my previous comment I had processed Image:Cusco_from_Sacsayhuamán_-_July_2003.jpg image with what I described as 'workaround' above. So probably next time problem occurs, workaround will be needed also... --JanSlupski 19:49, 7 Apr 2005 (EDT)

Recentchanges missing language links

The Special:Recentchanges page no longer links to the other language versions of Wikitravel. Jpatokal 23:09, 4 May 2005 (EDT)

Recent changes header changed

The Special:Recentchanges page header no longer points at the template text at Wikitravel:Recentchanges, which contains all the interesting text that provides all those useful links. Previously this was at MediaWiki:Recentchangestext. Perhaps a Template:Recentchangestext is needed - or something else. - Huttite 22:57, 21 May 2005 (EDT)

Please improve the title for search engines

Hi, I've noticed that where the page title used to be "page_name Wikitravel, The Free Travel Guide" the "Free travel guide" part is gone, and has been for a while. I thing that our search engine ranks are probably going to be higher with that text in there. -- Mark 11:45, 13 May 2005 (EDT)

Special pages show underscores in page titles

Special pages such as Special:Deadendpages, Special:Popularpages, Special:Shortpages, Special:Longpages, Special:Ancientpages, (Special:Uncategorizedpages) and Special:Lonelypages show underscores (_) instead of blanks or spaces ( ) in page titles.

Blanks or spaces do not show as undescores on Special:Newpages, Special:Wantedpages and most notably Special:Allpages. Shouldn't the page title be displayed the same in all cases? (This may have been a long term issue, but I cannot remember it happening before the 1.4.3 upgrade.) -- Huttite 22:15, 21 May 2005 (EDT)

No cutoff for Watchlist

The watchlist shows the last change for all items, regardless of what's selected for Days or Hours. -- Paul Richter 03:46, 23 May 2005 (EDT)

SVG images inaccessible

SVG image pages now have a small gif image which is created from part, but not all of the svg image to which the page refers. Unfortunately this means that the svg image itself cannot be accessed. -- Mark 05:18, 3 Jun 2005 (EDT)

As this is a serious issue I would propose to disable the rendering of SVG images completely. We'll need a bitmapped version of each image anyway so this feature is IMHO unnecessary for Wikitravel. --Srml 06:16, 6 Jul 2005 (EDT)
The images can still be accessed from the image history, which links directly to the SVG files. Jpatokal 07:07, 21 Dec 2005 (EST)

History for SVG files also seems to be badly messed up -- new versions are accepted, but only the original version is shown (see Image:Singapore.svg). Jpatokal 10:49, 6 Jan 2006 (EST)

Attribution footer acting strangely

I've noticed that on some pages, the "Creative Commons" logo is superimposed over the attribution text. Some people's user names are no longer clickable, and if you move your mouse cursor across the words, a contributor's user name will show up.

I don't know if this is just an incompatibility with the browser I'm using (Safari 1.2.4) or not. -- Mikito 16:50, 17 Jun 2005 (EDT)

I suspect a browser issue, Mozilla/WinXP is fine. Jpatokal 23:36, 22 Jun 2005 (EDT)

Japanese Style Sheet

When User:Mnd adds the ja: links to our pages [1], and then I look at them, the "navigation", "toolbox", "copyright" and other stuff is in Japanese. Wrh2 reports that it goes away when the page is edited by an en: user. Maybe caching issue on server? -- Colin 16:59, 15 Sep 2005 (EDT)

Actually all you have to do is force the re-caching by viewing the page using a URL like this one: http://wikitravel.org/wiki/en/index.php?title=Wikitravel:Neutral_point_of_view. Of course it would be easier for Evan, who could just delete all of the related cached html files. The fix is to make the Cache404 user have a language pref. -- Mark 02:01, 16 Sep 2005 (EDT)

Rewriting history??

My user page was spam-vandalized and has been reverted (thanks, J)... but the history has somehow become messed up.

The following change, attributed to myself, is incorrect:

http://wikitravel.org/wiki/en/index.php?title=User:Paul_Richter&diff=prev&oldid=124081

I'm absolutely sure that this change consisted of adding new text, not wiping out the page. And now that change is completely gone! -- Paul Richter 05:28, 12 Oct 2005 (EDT)

This was detected during the coolhost dot biz attack, I'd guess the concurrent spambot edits somehow managed to screw up the version history. You'll also notice that, if you click 'edit' for a history version, you'll end up editing a different page...! Jpatokal 05:49, 12 Oct 2005 (EDT)
I'm going to try to recover at least some of these edits from the daily backups. --Evan 07:13, 12 Oct 2005 (EDT)

Umm.. Sorry I had to change Jpatokal's text as coolhost(dot)biz is blocked by spam filter and wasn't letting my subsequent edit through! --Ravikiran 14:00, 9 Nov 2005 (EST)

Buffer Overflow?

Check this out[2]. Someone vandalised the Ulaanbaatar page and I reverted it. But the vandalism consisted of putting a huge amount of nonsense text. That seems to be crashing the "difference engine". Try comparing the vandalised version with any other version to reproduce the bug --Ravikiran 13:57, 9 Nov 2005 (EST)

Two pages have the same name

The page Central Oahu (Oahu) shows up in a search as being two pages with one name. (The second has 0 bytes.) They appear to have been created by the same user at the same time - possibly by double clicking the submit button on the entry form. The page(s) are slated for deletion but I thought it worth a mention here. Page name show up in the orphaned pages and the dead end pages even when the applicable page is neither. -- Huttite 21:02, 10 Dec 2005 (EST)

Deletion fixed this problem. I deleted the page once and wound up with two deleted edits! Problem solved. -- Huttite 18:54, 28 Dec 2005 (EST)

Links to namespace are broken

Following a link to a page in the Wikitravel: namespace results in a page without the toolbox and logo, as if I had asked for the printable version. Attempting to follow a link on that page results in an error "Protocol not supported: wikitravel", because the link begins "wikitravel:" instead of "http:". I think this problem dates from the server move. I'm using Konqueror 3.4.0.-phma 21:59, 17 Dec 2005 (EST)

Statistics broken in ja, nl

nl:Speciaal:Statistics has non-stub page count, number of views and number of edits broken. ja:特別:Statistics has number of views broken. Jpatokal 00:03, 20 Dec 2005 (EST)

I'll figure out how to get rid of that "number of views" number. It's hidden on pages, but not on the statistics. It's never going to be correct, since most pages are cached and MediaWiki never knows about the number of reads.
I'll try and update that statistics info. --Evan 22:16, 20 Dec 2005 (EST)

Upper/lowercase [[Wikipedia:Wiener Neustadt]]

Just [[WikiPedia:Wiener Neustadt]] works ... ;-) --Roland2 06:03, 23 Dec 2005 (EST)

See Wikitravel:links to Wikipedia; that's documented and by design. We use an InterWiki map that comes with MediaWiki and is used by many other wikis and wiki engines. Since so many wiki engines use CamelCase for wiki links and interwiki prefixes, the "standard map" uses camel case, too. It's also a subtle reminder to newly-arrived Wikipedians that the WikiPedia prefix goes to the Wikipedia "main" namespace, not to the Wikipedia project namespace (which has the "Wikipedia" prefix on that wiki). --Evan 09:46, 23 Dec 2005 (EST)

Arguments to RDF templates must be in URL form

{{IsIn|Upper_Austria}} does not work without underscores. --Roland2 06:11, 23 Dec 2005 (EST)

I'm not sure that's a bug, since it's documented and by design. See Wikitravel:RDF, Wikitravel:Breadcrumb navigation. RDF requires URIs for places, and the template mechanism in MediaWiki doesn't have a way to URI-encode template arguments. That's coming in future versions, I understand. --Evan 09:25, 23 Dec 2005 (EST)

Spam Filter PHP Errors

When banned content is added to the page and then saved, the PHP code throws out the following HTML text before the start of the HTML page header and then throws an Internal Error HTML page.

Warning: preg_match(): Unknown modifier 'l' in /var/www/wikitravel/mw/extensions/BannedContent.php on line 46

Warning: preg_match(): Unknown modifier '[' in /var/www/wikitravel/mw/extensions/BannedContent.php on line 46

Shouldn't the error messages either be suppressed or thrown after the HTML header starts? Also the Preview does NOT give any warning that the page contains banned content - perhaps it should. It might be better if Banned Content dropped the user back into the preview screen or somehow gave the user the option to re-edit the content they attempted to post. An internal error that trashes (unsaved) posted content without warning is rather obnoxious for the innocent user who unwittingly posts a banned URL. Mind you I am happy that the content does get banned, and the obnoxious and untidy way it happens is probably what spammers deserve. -- Huttite 18:48, 28 Dec 2005 (EST)

I think this is fixed (w/r/t warnings); I agree that the error should work better. --Evan 19:27, 10 Feb 2006 (EST)

Inaccessible pages

Special:Lonelypages list the page as being an orphan. However this link goes to. The English version of the page cannot be accessed as it shows up as a Bad Title. -- Huttite 19:07, 28 Dec 2005 (EST)

Hurgh. Yes, that's kind of a funky problem. Before the launch of the Dutch-language Wikitravel, "nl:" had no meaning and articles that started with "nl" were just regular articles in the "main" namespace. I thought I had caught them all before the launch, but I guess I missed a couple. Now, they're links to the Dutch-language version.
I'm not sure what to do about this. Those pre-launch article names aren't part of the process for getting a new language version started, so I don't think it's a problem with changing our processes. Maybe there's a technical fix here, like setting up fake prefixes for those languages that don't yet have a Wikitravel version? That way, attempt to make things like nl:Wikitravel:Welkom in the regular namespace would instead redirect to a page explaining why such pages can't be created an how to start a new language version. --21:02, 28 Dec 2005 (EST)
Perhaps we should specify that when creating and translating the initial Wikitravel help and welcome pages for a new language version these pages are part of the language expedition and should be created as a sub page. When the language version is up and running the translated content is able to be copied to the new language version and the English version pages are redirected. This would also mean that there is a clear breadcrumb relationship to the language version for foreign lanuage content. -- Huttite 21:49, 28 Dec 2005 (EST)
For the record the following inaccessible and potentially inaccessible pages exist in the main namespace.
-- Huttite 02:30, 29 Dec 2005 (EST)

Talk:Finding_accommodation - cyclic redirect

Talk:Ko_Pha_Ngan - cyclic redirect

Mexico_City/Coyoacán (4899 bytes)

Misplaced MediaWiki namespace pages

While using Special:Allpages [3] to track down errant lanuage version pages containing : in their name, I discovered these 3 pages listed in the main namespace.

Interestingly, the what links here [4] to MediaWiki:Recentchangestext shows it has redirect links from both Mediawiki:Recentchanges and Mediawiki:Recentchangestext. Also MediaWiki:Recentchangestext is listed on Special:Lonelypages and Special:Deadendpages. Lastly these pages also exist in the MediaWiki namespace [5]. -- Huttite 02:30, 29 Dec 2005 (EST)

Breadcrumb navigation does not display on redirected pages

I notice that the IsIn Breadcrumb navigation does not display on redirected pages. See UTP for an example. Is there any way to overcome this, short of putting IsIn on all the redirected pages too? -- Huttite 17:31, 31 Dec 2005 (EST)

The breadcrumb navigation goes in the same "slot" in the Mediawiki skin as the "Redirected from X" section. I'll take some time to make this work better. --Evan 20:45, 31 Dec 2005 (EST)
Content of UTP is #REDIRECT [[Pattaya#U-Tapao]] - but the #U-Tapao part doesn't work (unlike Pattaya#U-Tapao) - could that be fixed?

Uploading image second time broken?

I tried to upload Image:Jodhpur from Mehrangarh Fort.jpg and Image:Mehrangarh Fort.jpg after making the images sharper. It gives some PHP error, says it got uploaded successfully, but does not get uploaded. The upload log shows it as uploaded though. --Ravikiran 08:39, 1 Jan 2006 (EST)

Me too. The PHP errors are:


Warning: preg_match(): Unknown modifier 'l' in /var/www/wikitravel/mw/extensions/BannedContent.php on line 46

Warning: preg_match(): Unknown modifier '[' in /var/www/wikitravel/mw/extensions/BannedContent.php on line 46

Warning: preg_match(): Unknown modifier 'f' in /var/www/wikitravel/mw/extensions/BannedContent.php on line 46

They appear at the start of the Page Source text before the Doctype and HTML header statements. The images appear to have been uploaded to the server, as I can draw the images down from the image directory but the images do not appear on the image page. For example: The image is [6] but Image:Swansea_Bay_and_Mumbles_Head.jpg is not updated. -- Huttite 03:02, 12 Jan 2006 (EST)


Pages ending in Period character

If a page ends in a period is it a different page but pages with and without periods get confused when they are cached but not when Index.php is used. For example: Compare User:Mark. which has a following period and is not User:Mark even though the same page is displayed. The User:Mark page is actually here [7], not here [8].

The problem also applies to Main Page.[9], which is confused with Main Page and shows up as both an Orphan and Dead End page. -- Huttite 17:07, 8 Jan 2006 (EST)

Fatal error: Call to a member function on a non-object

This link [10] gets me the following every time: Jpatokal 05:36, 22 Jan 2006 (EST)

Fatal error: Call to a member function on a non-object in
/var/www/wikitravel/mw/extensions/Cache404.php on line 736
So does [11]. It appears that Malacca_ৠstateৡ does not exist. -- Huttite 06:43, 22 Jan 2006 (EST)
But this works: http://wikitravel.org/en/Malacca_%28state%29. The link above is directly from the Recent changes page...? Jpatokal 06:47, 22 Jan 2006 (EST)
When I look at recent changes I get [12], which doesn't have the %2528 and %2529 characters and instead give %28 and %29 for ( and ). Could this be a browser related setting? -- Huttite 06:57, 22 Jan 2006 (EST)
No, it's silly code in MediaWiki. It has URL-encoded "(" and ")" twice -- once to make "%28" and "%29", another time to make "%2528" and "%2529". "%25" is the URL code for "%". Anywho, there's some code somewhere in Mediawiki that reverses the error, but my code was messing it up. I moved my code out of the way, and it seems to work fine now. --Evan 12:36, 22 Jan 2006 (EST)

Cache404 cached spam filter message

This is really wierd. User:Jonboy reported getting a spam filter error when trying to read the Wikitravel:External links page. When I went to check it out it turned out that the cached version of the html page had the spam filter reject message on it. It was easy enough to fix, but we should really fix the root problem, if it can be reproduced. -- Mark 05:17, 11 Feb 2006 (EST)

The spam filter wasn't setting the right error flags, so I a) checked to make sure that the error flags were being set and b) changed the caching extension to check a wider variety of flags. This problem doesn't seem to be happening any more. --Evan 11:39, 13 Feb 2006 (EST)

RDF and swedish letters

It seems like RDF cannot handle non-ASCII text (?), and especially not the swedish letters Å, Ä and Ö. Any solution? Riggwelter 16:10, 20 Feb 2006 (EST)

Shared links are bad

For images stored on shared like Image:LocationSwedenVästmanland.png, it says please see the file description page there for a complete description. Clicking on the link takes me to commons.wikipedia.org instead of our shared. -- Colin 17:41, 23 February 2006 (EST)

Hurgh. It doesn't use the interwiki anymore; just a prefix, and the default is the wikimedia one. I've set it and cleared the cache, and it should be working now. --Evan 18:24, 23 February 2006 (EST)

Main Page

At the moment, main page is

   Fatal error: Cannot instantiate non-existent class: in /var/www/wikitravel/mw/includes/SkinTemplate.php on line 136

-- Colin 20:04, 23 February 2006 (EST)

Not sure if I fixed it or not, but purging it from the cache with http://wikitravel.org/wiki/en/index.php?title=Main_Page&action=purge seems to have resolved the problem for me. -- Ryan 20:07, 23 February 2006 (EST)
Thanks. That's quite a url. -- Colin 20:31, 23 February 2006 (EST)
Just happened again. -- 23:33, 23 February 2006 (EST)
There's a link on Special:Preferences that shows all the available skins, and lets you preview each skin by showing the main page in that skin. However, it was listing some old skins that no longer exist in MediaWiki (!), so they were coming up with that PHP error.
I've limited the skins shown to the actual available skins (one), and it shouldn't happen again. --Evan 11:55, 24 February 2006 (EST)

S/W Update error?

Hm, the toolbox field and "other languages" field seem to have fallen down to the very bottom of the page following the S/W upgrade. Also, the navigation/search fields seem to be put on top of eachother when viewing certain pages. Riggwelter 03:49, 24 February 2006 (EST)

I don't see this in Firefox 1.5.0.1 but do see it using IE 7.0. -- Ryan 04:00, 24 February 2006 (EST)
It looks like there's an extra div tag in there. I understand however that one of the next things on the list is the installation of a new skin which should take care of this while introducing many new, interesting, and unexpected bugs.-- Mark 04:08, 24 February 2006 (EST)
Yep, the div closing tag for one of the conditional boxes was outside the "if" block for the condition. I've changed it and purged the cache; should be OK now. --Evan 11:43, 24 February 2006 (EST)

Cannot confirm email address

Seems that I'm unable to confirm my email address. Reproduce:

  • have account with unconfirmed email
  • go to preferences
  • click on Confirm your e-mail address
  • click Mail a confirmation code
  • open Wikitravel e-mail address confirmation in an email client and click confirmation link there
  • getting message Your e-mail address has now been confirmed.
  • your mail (in preference page) is still unconfirmed, and you still cannot send emails via User Page -> Email this user

--JanSlupski 10:17, 24 February 2006 (EST)

I had the same problem; I've turned off the email authentication (on by default in mw 1.5.x) for now. --Evan 11:22, 24 February 2006 (EST)

isIn problems

I've noticed several situations where the isIn seemed to not be working including Mississippi and Afghanistan. Clearing the cache using the action=purge URL didn't seem to help, but moving the isIn tag above the other language versions and the Wikipedia tag did seem to solve the problem. I haven't tried to test on other articles, but seems like a possible bug. -- Ryan 19:54, 26 February 2006 (EST)

I was running a maintenance process on the server, and it was sticking URLs like 'http://localhost/en/Mississippi' into the RDF cache. I fixed the process and cleared all the caches, and it should be working fine now. --Evan 20:07, 26 February 2006 (EST)

Searching for phrases

If I search for any phrase with double quotes, then I don't just get hits for the phrase. For example, searching for "food air" shouldn't get any hits, but it does. Jonboy 22:56, 4 March 2006 (EST)

2 edits at the same time - lost data

I had just started the Stenness article and after the first save had spent 1/2 hour editing it. When I tried to save I received a message that the article had changed and I was back to editing the amended article with all my info lost. I probably would not have had the problem if I was editing an individual section rather than the entire article. -- DanielC 07:59, 6 March 2006 (EST)

What links here - incomplete results

Example: Special:Whatlinkshere/Ontario_(province) - shows that pages that link to Ontario_(province) include Ontario, but does not show pages that link to Ontario (see Special:Whatlinkshere/Ontario for confirmation).

For some pages it IS working OK (ie listing "what links to what links here") while for others it's not (ie only listing "what links here" but NOT listing "what links to what links here").

The second level ("what links to what links here") only is done for redirects. This is by design, not a bug. --Evan 22:10, 10 March 2006 (EST)
...and Ontario is a disambiguation, not a redirect - that's the part I needed to get to grips with. Thanks for the explanation.

Variants

Actions

Destination Docents

In other languages