Help Wikitravel grow by contributing to an article! Learn how.

Difference between revisions of "Wikitravel:Bug reports"

From Wikitravel
Jump to: navigation, search
(Text getting cut off: Move to shared:)
m (interwiki redirects confuse tatatabot (which I hope is still in operation?))
 
(9 intermediate revisions by 4 users not shown)
Line 1: Line 1:
This is the '''old page''' for bug reports for the Wikitravel installation of Mediawiki 1.6.8 (see [[Special:Version]]). Bugs that have been verified as fixed already are under [[Wikitravel:Fixed bugs]].  For older bug reports, see the [[Wikitravel:bug report archives]]. For new ideas, try [[Wikitravel:Feature requests]].
+
'''''[[:shared:Wikitravel Shared:Technical requests]]'''''
 
+
New bugs should be reported on the [[:shared:Wikitravel Shared:Technical requests|Technical requests]] page on [[:shared:Main Page|Wikitravel Shared]].
+
 
+
<!-- interwiki links here to save them from getting moved. -->
+
 
+
[[de:Wikitravel:Fehlerberichte]]
+
[[fr:Wikitravel:Rapport d'erreurs]]
+
[[pt:Wikitravel:Relatório de erros]]
+
 
+
 
+
 
+
== Breadcrumb navigation should use RDF first, sub-pages as a backup ==
+
 
+
Currently if a page is a sub-page of another page (e.g. [[Singapore/Sentosa]]), it's automatically marked as being "in" the parent page (e.g. [[Singapore]]). You should be able to override this with an <nowiki>{{isIn|Somewhere_Else}}</nowiki> tag. --[[User:Evan|Evan]] 15:53, 17 June 2006 (EDT)
+
 
+
== Change contents of "url" section of listings tags to "web" or "website" ==
+
 
+
For [[Wikitravel talk:Listings|Listings]], change the outward link to a stock phrase (web or website) or (better) an auto-numbered link. --[[User:Evan|Evan]] 16:03, 17 June 2006 (EDT)
+
 
+
== Get rid of extra br after listings tags ==
+
 
+
For [[Wikitravel talk:Listings|Listings]], an extra <nowiki><br/></nowiki> tag appears at the end of each listing. It would be good to get rid of these. --[[User:Evan|Evan]] 16:03, 17 June 2006 (EDT)
+
 
+
== Change [[Special:Export]] output so it includes real names ==
+
 
+
The export format for MediaWiki doesn't export users' real names, and it would be nice for downstream publishers if it did. --[[User:Evan|Evan]] 16:10, 17 June 2006 (EDT)
+
 
+
== Add "email this user" on client side, if user is logged in ==
+
 
+
The email this user link doesn't always show up on user pages, since it's only show for logged-in users. IWBNI it were added on the client-side with Javascript, so that if you're logged in you always see this link. --[[User:Evan|Evan]]
+
16:10, 17 June 2006 (EDT)
+
 
+
== TOC takes up too much space ==
+
 
+
The table of contents in a page makes a lot of whitespace right at the beginning of an article (see http://evan.prodromou.name/images/San_Diego.png for an example). It would be nice to move it to the left nav area or to a new nav area on the right side of the screen. See [[Wikitravel talk:Table of contents location]] for more discussion on the issue.
+
 
+
It would be nice to make this optional per-language version. For example, de: users seem really opposed to it and are happy with other solutions for working around the whitespace problem. --[[User:Evan|Evan]] 16:41, 17 June 2006 (EDT)
+
 
+
:There's now a review version up for consideration. It's in very raw form and I'm still testing it, but it's worth looking at. Compare: http://wikitravel.org/review/San_Diego. --[[User:Evan|Evan]] 13:03, 29 June 2006 (EDT)
+
 
+
==Today's log on ja:==
+
The 'Today's Log' (今日のログ) link in the Japanese navbar links to "Wikitravel:2006年6月18日 (日)", whereas previous entries used just <nowiki>"Wikitravel:{{CURRENTYEAR}}年{{CURRENTMONTHNAME}}{{CURRENTDAY}}日"</nowiki>.  Could the rather useless weekday be stripped off? [[User:Jpatokal|Jpatokal]] 23:18, 17 June 2006 (EDT)
+
 
+
:Yes it could! It's actually configurable with a MediaWiki: format article, [[:ja:MediaWiki:Logbooktitle]]. I'll take a poke at it, but you should look at [[Wikitravel:27 April 2006]] for details on how it works. --[[User:Evan|Evan]] 23:28, 17 June 2006 (EDT)
+
 
+
==Raw signature==
+
 
+
In the [[Special:Preferences|Preferences]] page, you can set a nickname and there is a box to check if you want a "raw signature." Every time I check the box, it says my preferences were saved but it's cleared again. Is this feature disabled? If it is, it would be better if the box didn't appear at all, or at least mention on [[Wikitravel:User preferences help|User preferences help]] that the box doesn't work. It's not a big deal but if I want a custom formatting for my signature, I have to type it myself now. [[User:Philbert2.71828|Philbert<sup><tt>2.71828</tt></sup>]] 14:47, 23 June 2006 (EDT)
+
 
+
:Yeah, that's a bug; raw signatures are being forced to off for everyone because of caching, but it doesn't really affect caching, so I figure it should be removed. Thanks for the report. --[[User:Evan|Evan]] 18:08, 23 June 2006 (EDT)
+
 
+
==Timezone (it)==
+
We've had some problems on the Wiktionary:it. The default timezone was EDT, non good for Italy. It has now been changed to CEST, and all seem to work really better.
+
BUT: if I am logged off, and watch the "Recent changes" page, I see allthing shifted: +2 hours. If something has been done at 20:31, it looks like it has been done at 22:31. When I log in, no problem, 20:31. If something has been done 10 minutes ago, it looks like it will be done in 1 hour and 50 minutes! (only when I'm logged off). Is there some way to correct this time too? [[User:DaniloP|Dennis]] 18:21, 30 June 2006 (EDT)
+
 
+
:I'll take a look. Since we changed the default timezone, you might need to go to the preferences page and re-set your timezone (which is stored as an offset from the default, not as an absolute value. --[[User:Evan|Evan]] 12:46, 1 July 2006 (EDT)
+
 
+
==isIn failure on shared==
+
 
+
I'm trying to set up the isIn for Cote d'Ivoire on shared (see [[:Image:LocationCotedIvoire.png]]), but the apostrophe causes problems, even if escaped.  The error is:
+
 
+
A database query syntax error has occurred. This may indicate a bug in the software. The last attempted database query was:
+
 
+
    (SQL query hidden)
+
 
+
from within function "getCategories". MySQL returned error "1064: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'Ivoire')' at line 1 (wikidb.internetbrands.com)".
+
 
+
-- [[User:Wrh2|Ryan]] 01:23, 1 July 2006 (EDT)
+
 
+
==Special pages list incomplete==
+
 
+
[[User:Rmx]] noted that [[Special:Specialpages]] doesn't always show all (or any) special pages. For admins, it seems to show the admin special pages but not the "normal" ones. But it comes and goes irregularly. I thought at first this might have to do with the new OpenID special pages, but after disabling them I saw the same behavior. --[[User:Evan|Evan]] 09:25, 23 July 2006 (EDT)
+
:This problem is on DE too.  I haven't checked any other language versions so I'm not sure about PL, FR, SV, ES, or RO.  -- [[User:Sapphire|Andrew Haggard (Sapphire)]] 09:49, 24 July 2006 (EDT)
+
::Here's an interesting... clue, maybe?  I tried guessing at the URL of one of the undisplayed Specialpages, and guessed wrong.  So the server gave me an error page telling me my page name was invalid, and giving me a pointer to [[Special:Specialpages]]... which ''worked''.  It's the exact same URL (unless that's a capital "eye" in "SpeciaI"), but it gave me the full list.  It worked a couple more times after that, then it didn't, and just now it did. {shrug}  Anyway, it's a possible work-around to get at that index. - [[User:TVerBeek|Todd VerBeek]] 18:44, 26 July 2006 (EDT)
+
:::I've hit the special link pages from several different pages and sometimes in a bit of a pattern, sometimes not - occasionally I make it through, but often I don't.  Its kind of random... -- [[User:Ilkirk|Ilkirk]] 19:11, 26 July 2006 (EDT)
+
 
+
:Bump. This is annoying me, just when I get motivated to  police new pages and new images. &mdash; [[User:Ravikiran r|Ravikiran]] 06:31, 6 August 2006 (EDT)
+
 
+
I can't seem to get any of the special pages options to show except for the admin only options.  How about others?  I'm using IE 7 and Mozilla Firefox. -- [[User:Sapphire|Sapphire]] 17:07, 10 August 2006 (EDT)
+
 
+
:So, it looks like this is a weird conjunction of bugs from eAccelerator, PHP 5, MediaWiki, and the planet Neptune. There's a bug report for MediaWiki [http://bugzilla.wikimedia.org/show_bug.cgi?id=6772 here]. I've applied the workaround and I'm more or less convinced myself that it's fixed. Please make a note here if you see this one showing up again. --[[User:Evan|Evan]] 20:19, 10 August 2006 (EDT)
+
 
+
==Login not working?==
+
I've just "logged in successfully" three times, but still remain anonymous.  What's going on?  This is happening on both en and ja. [[User:202.156.2.35|202.156.2.35]] 23:44, 24 July 2006 (EDT) (aka Jpatokal)
+
 
+
: Something is messed up - I get a "Sorry! We could not process your edit due to a loss of session data. Please try again. If it still doesn't work, try logging out and logging back in." when I try to edit while logged in.  I '''can''' log in successfully though. -- [[User:70.142.1.219|70.142.1.219]] 23:50, 24 July 2006 (EDT) ([[User:Wrh2|Ryan]])
+
 
+
:: It is showing me as logged in, but I seem to have lost rollback powers. Plus, this signature will tell whether I am logged in or not &mdash; [[User:59.163.13.121|59.163.13.121]] 02:32, 25 July 2006 (EDT) ([[User:ravikiran_r|Ravikiran]])
+
 
+
:::I'm seeing the same behavior as 70... I mean "Ryan".  A glitch with OpenID would be my first hypothesis.  Evan and Maj get back from a camping trip later today... - [[User:66.93.200.116|66.93.200.116]] 07:44, 25 July 2006 (EDT) ([[User:TVerBeek|Todd VerBeek]])
+
 
+
::::This should be fixed at this point -- one of the temp drives on the server ran out of space. Of course, we should know about that before it starts interfering with the operation of the site... we're putting alarms into place to keep this from happening again. Thanks to all who sent email, I think this should be back on track now. If you see any more weird behavior, try logging out and logging back in again. --[[User:Evan|Evan]] 12:43, 25 July 2006 (EDT)
+
 
+
== Not shown as logged in if JS is turned off ==
+
 
+
If JavaScript is turned off in your browser, the "personal links" in the upper right-hand corner don't show your name and talk page. (This is because of our server-side caching -- everyone's reading the same HTML pages, slightly decorated on the client side by JavaScript.) We should probably have some text to this effect on [[Special:Userlogin]]. --[[User:Evan|Evan]] 22:23, 25 July 2006 (EDT)
+
 
+
==Disambiguation pages special page==
+
The [[Special:Disambiguations|Disambiguation pages special page]] requires that [[Wikitravel:Disambiguation pages|disambiguation pages]] have [[Template:Disambig]] on them rather than [[Template:Disamb]] (our standard). [[Template:Disambig]] is empty and a deleted page (twice). Can the target template name be changed so the special page works correctly? I do not like the other alternative of changing all the disambiguation page templates. -- [[User:Huttite|Huttite]] 19:54, 27 July 2006 (EDT)
+
:I tried creating that template a while back as a test to see if it could de-orphan the disambig pages without having to manually index each one, but a couple admins freaked out over the fact that I'd created a redundant template, so I gave up on it.  (I figure a bot could update the existing pages without too much effort or disruption.) - [[User:TVerBeek|Todd VerBeek]] 20:08, 27 July 2006 (EDT)
+
::It actually just needed a change in the [[Mediawiki:disambiguationspage]] file. Typically if there's a "magic word" like this -- a special string like "Template:disambig" -- you should look in [[Special:Allmessages]] to see if the string exists there.
+
::One problem I see is that [[:Template:disamb]] links to [[Wikitravel:Disambiguation pages]], which in turn links to [[:Template:disamb]], so there's kind of a loop. We may want to think about breaking that up. --[[User:Evan|Evan]] 20:43, 27 July 2006 (EDT)
+
 
+
==nl's main page==
+
I have just dropped by the Main page of Dutch Wikitravel ([[:nl:Hoofdpagina]]) and it's apparently showing the page's printable version instead of the "normal" version. [[User:Rmx|Ricardo (Rmx)]] 22:25, 30 July 2006 (EDT)
+
:Thanks for the heads up... I just took a look and all the other language versions seem fine, as well as all the other pages in nl... weirdness. [[User:Maj|Maj]] 00:11, 31 July 2006 (EDT)
+
::How's it look now? It didn't look like it should have two minutes ago, but it looks perfectly fine in my browser now. -- [[User:Sapphire|Andrew Haggard (Sapphire)]] 00:38, 31 July 2006 (EDT)
+
:::Err, it looks fine now... not that that makes it any less weird, but I guess I can go to sleep now. [[User:Maj|Maj]] 00:40, 31 July 2006 (EDT)
+
::::Did you do anything?  The only I thing that I did was log in, went to the recent changes page attempted a revert, then the main page was showing properly so I took the opportunity to purge the cache.  If that makes any sense - it doesn't to me. -- [[User:Sapphire|Andrew Haggard (Sapphire)]] 00:45, 31 July 2006 (EDT)
+
:Just thought I'd let you know that I had the exact same problem in the en version a second ago. I deleted the temporary internet files and it refreshed the page and it's fine now... Don't know if theres something up with that, but I thought Id let you all know about it. -- [[User:Tsandell|Tim]] 04:51, 8 August 2006 (EDT)
+
 
+
==Sorry! We could not process your edit==
+
Whenever I try to edit, I get an error message saying
+
Sorry! We could not process your edit due to a loss of session data. Please try again. If it still doesn't work, try logging out and logging back in.
+
 
+
This does not stop me from editing or saving. I have set the "Show preview before edit box" option in my preferences, so it shows me a preview when I edit anything. Others might not see the same error.  &mdash; [[User:Ravikiran r|Ravikiran]] 04:31, 31 July 2006 (EDT)
+
 
+
:That usually happens when you've taken a long time between starting an edit and saving it. I'm not sure why it's there, but I'm sure there's a good reason for it. B-) Is it happening even for very ''short'' edits? --[[User:Evan|Evan]] 23:37, 11 August 2006 (EDT)
+
 
+
=="Protect" and "Delete" tag==
+
Some of my authorized functions as an administrator (ja:) seems malfunctioning. When I am trying to use the "Protect" function and click the tag, the name of the article changes to a garbage character (e.g. "釜ヶ崎" to "釜ヶ崁Eaction=protect"), and can not protect the article. And this is often the case with "Delete" function. Would you check the systems and correct them? [[User:Shoestring|Shoestring]] 23:14, 11 August 2006 (EDT)
+
 
+
(Addition) The article which has some namespace (such as [[:ja:Help:編集の仕方|Help:編集の仕方]]) is also undeletable. In order to avoid further vandalism, I tried to protect this article temporary and click the "Protect" tug of this article. It seemed to work, but actually the Main page had protected instead.--[[User:Shoestring|Shoestring]] 20:37, 12 August 2006 (EDT)
+
 
+
: Oddly enough my functions work fine.  I think Shoestring has had the same problem ever since the database conversion thingy way back... [[User:Jpatokal|Jpatokal]] 03:01, 12 August 2006 (EDT)
+
 
+
:: I was just able to do it, too. It's not really that useful if Shoestring can't do it, though. Since those tabs are built by JavaScript on the client side, I assume that there's some browser incompatibility at work. So I can test with your browser, Shoestring, can you tell me which one it is? --[[User:Evan|Evan]] 20:47, 12 August 2006 (EDT)
+
 
+
:::Sorry but I don't know much about the technology, so I have no idea whether I can answer your question properly. Browser? My Internet browser is quite common..., the Microsoft Internet Explorer (probably 6, not at least 7). And the version of Java is JRE 1.5.0_06 (property says so). Umm, but I don't think its not enough..., what kind of information do I have to give you? --[[User:Shoestring|Shoestring]] 23:39, 12 August 2006 (EDT)
+
 
+
==Display error of the index of Ja: Special page==
+
When I click the "Special page" for displaying its index, it displays only partially, or some cases it displays nothing except a title of the page. It happens quite so often recently. Sometimes it recovers to a normal (when I am trying for several times for display), but it’s very inconvenient. Could you check the systems and correct? [[User:Shoestring|Shoestring]] 23:14, 11 August 2006 (EDT)
+
 
+
:Argh. I thought I fixed this last night (see above). Does it still happen? --[[User:Evan|Evan]] 23:28, 11 August 2006 (EDT)
+
 
+
::Sorry, I missed checking the page above. Yerh...it works quite well now. Thanks. [[User:Shoestring|Shoestring]] 05:40, 12 August 2006 (EDT)
+

Latest revision as of 00:46, 7 May 2010

shared:Wikitravel Shared:Technical requests

Variants

Actions

Destination Docents

In other languages