The center for all Wikitravel images!

Tech:Search and Find Behaviour

From Wikitravel Shared
Jump to: navigation, search

Moved from en:Wikitravel:Old bug reports by Evan


When I type "Bolivar" into the Find box and hit the "Search" button, everything seems to work OK. (There is no article on this city yet, but the search tool finds 7 articles where "Bolivar" (a city, a person, etc.) is mentioned).

When I type "Bolivar" into the Find box and just hit enter (or punch "Go"), the find tool only finds 1 article, with the message

 . No page with this exact title exists, trying full text search.
 .    * Bolivia 71% (****) 

I expected that a "full text search" would find all 7 articles that "Search" does.

Is this a bug in the MediaWiki software?

-- DavidCary 23:58, 18 Jun 2004 (EDT)

No. There are 2 different searches that can be invoked. The article title search is invoked by clicking on the Go button in either the Search Box in the sidebar or the Find Box at the bottom of the page. Pressing the Enter key in either of these boxes defaults to this search - which is faster. When your cursor is in one of these boxes note that the Go button is highlighted as this is the button that is selected when the Enter key is pressed. The full text search can only be invoked by clicking on the Search button with the mouse or pressing the Tab key twice to highlight the Search button before pressing the Enter key. It is not a fault, just a default. -- Huttite 00:38, 19 Jun 2004 (EDT)

In that case, please change the (misleading) message "No page with this exact title exists, trying full text search." to something more like "No page with this exact title exists, searching for similar titles."

-- DavidCary 21:16, 19 Aug 2004 (EDT)


Another oddity:

"Search" unexpectedly fails to find something that "Go" succeeds in finding.

If I type "davidcary" into the search box and hit the "Go" button, I get 1 hit ( en:User:DavidCary, as expected ).

If I type "davidcary" into the search box and hit the "search" button, I get "... 0 results ... No article title matches ... No article text matches".

  • I expected the "search" button to at *least* get all the hits that the "go" button finds.
  • I expected to see a list of all the "talk" pages that I signed. So apparently the "talk" pages aren't indexed at all ?

--DavidCary 10:43, 28 Aug 2004 (EDT)